Обновление php до последней версии 2 важные причины

Обновление php до последней версии прежде всего, обеспечит более быструю и надежную работу сайта, оптимизацию страниц и улучшенную структуру по мнению поисковиков. Но не у всех получается правильно осуществить данное обновление.

О том когда и как, а главное, зачем переходить на новую версию php и не наделать ошибок, мы и поговорим в этом посте.

обновление php

Содержание:

  1. Когда переходить на последнюю версию php
  2. Причины для обновления php
  3. Как узнать версию php
  4. Обновление php на сервере для wordpress
  5. Проверка расширений на совместимость с php 7
  6. Обновление версии php joomla

Когда переходить на последнюю версию php

О необходимости обновления версии php можно узнать как самостоятельно (проверить скорость загрузки), так и получив уведомление от своего хостинг-провайдера. Кроме того, при использовании готовых движков, можно включить режим отладки системы и при установке расширений у которых используется старая версия php, система сама выдаст предупреждение.

Так же проверить код сайта на ошибки можно валидатором (https://validator.w3.org/). Еще один способ несовместимости — это установка расширений для своего движка. Особенно это касается новых или обновленных расширений (если создан на php). В них всегда все новое, в том числе и сам php-код.

Причины для обновления php

Необходимо отметить 2 самые важные причины — это безопасность и работоспособность всего сайта. Еще совсем недавно все администраторы знали о прекращении обновления php версии 5.2, а сейчас, по прошествии всего чуть меньше двух лет, язык программирования php уже доступен в 7 версии.

Говоря простым языком, обновлено полностью ядро php, появились новые и упрощены старые функции. В результате увеличения передачи данных, увеличилась и скорость работы.

Что касается cms-систем, то joomla например, уже имеет последнюю версию php после того как вышла версия 3.7 этого движка. Конечно и популярный блоговый движок wordpress тоже может работать на последней версии php, нужно только правильно осуществить этот переход.

Сам движок может и будет работать без проблем, но работоспособность напрямую зависит от настроек параметров вашего хостинга. Все эти настройки необходимо настроить самостоятельно, либо обратиться в службу поддержки хостинга.

В связи с этим, краткая рекомендация.
Если вы не дождались ответа от своего хостинг-провайдера, меняйте не задумываясь такой хостинг. Лично я пользуюсь услугами хостинга beget.

Владельцам самописных сайтов использующих php, так же необходимо позаботиться о переходе на новую версию, но это уже отдельная тема и владельцы написавшие такой сайт самостоятельно, знают как это сделать.

Что касается администраторов занимающихся только управлением таких сайтов и не имеющих необходимых знаний, то здесь необходимо обратиться к владельцу сайта или к программисту создавшему движок.

Как узнать версию php

Прежде всего любому администратору необходимо иметь полную информацию о своем программном обеспечении с помощью которого работает сайт, включая и версию php, если конечно именно этот язык программирования использован для работы проекта.

Способов проверки достаточно много, самыми простыми являются непосредственно проверка версии php в аккаунте хостинга и второй — создание файла проверки версии php.

Про аккаунт на хостинге, каждый владелец сайта все знает сам, а вот про проверку с помощью файла, рассмотрим подробнее.

Для этого создаем файл в любом редакторе со следующим содержимым:
<?php phpinfo(); ?> и сохраняем под тем же именем phpinfo.php

Затем данных файл нужно закачать в корень своего сайта и обратиться к нему в адресной строке своего браузера (http://ваш_домен/phpinfo.php).

В результате получим всю необходимую информацию касающуюся не только версии php, но и все что нужно для администратора.

Узнать версию php

Обновление php на сервере для wordpress

Все популярные cms-системы, в том числе и wordpress, часто обновляются и имеют последнюю версию языка программирования и частенько новый функционал. Связано это прежде всего с безопасностью и с обновлениями программного кода.

На этом примере рассмотрим практику обновления php непосредственно на хостинге. Хорошо что владельцам cms-систем нет надобности обновлять весь программный код cms, для этого есть разработчики.

А вот настроить совместимость версий php хостинга и например wordpress, это уже дело администратора сайта. Собственно ради этого и написана данная статья.

Любой администратор знает что обновление php на сервере делается из контрольной панели хостинга двумя кликами мыши. Выбрал необходимую версию php и нажал кнопку «сохранить».

Ну а дальше наблюдаем недоступность своего проекта.

В большинстве случаев это происходит по причине несовместимости установленных расширений с последними версиями php. Поэтому важно следить за обновлениями и стараться не устанавливать расширения, которые давно не обновлялись разработчиком.

Совсем не важно знать структура wordpress или другого движка, а достаточно понимать что все изменения происходят именно по этой причине.

А раз так, то нужно все это дело проверить. Но расширений может быть не один десяток (плагины для wordpress) и проверить такое количество на совместимость, просто не реально!

Как быть?

Проверка расширений на совместимость с php 7

Как ни странно, но для wordpress например, можно установить еще один плагин Compatibility php, который и поможет узнать какие установленные плагины не дают нормально работать системе.

Это отличный и простой способ проверить совместимость вашего сайта с PHP 7. Причем проверить можно практически все, включая тему для wordpress.

Установка стандартная и после этого в панели инструментов появится дополнительная вкладка PHP Compatibility.

PHP Compatibility

Плагин проверит все установленные плагины движка на совместимость что и позволит нам сократить время на поиск несовместимых расширений.

Чтобы внимательно рассмотреть, нажмите мышкой на изображение.

На скриншоте видно, что после нажатия на кнопку «Scan site again», плагин выдал всю информацию по установленным расширения. Наглядно виден разноцветный результат проверки.

Настройки PHP Compatibility

Содержимое подозрительных плагинов можно просмотреть нажав на ссылку справа и увидеть адрес этой ошибки.

ошибка PHP Compatibility

Таким образом, из установленных 23-х плагинов на блоге, необходимо отключить или удалить всего 3. Тем самым можно обеспечить себе уверенность в том, что обновление php пройдет без проблем.

Если не жалко времени, можно обойтись ручным способом удалить или отключить все плагины, а после настройки сервера на php 7, постепенно включать их по одному и проверять работу.

В этом случае нужно либо помнить все настройки, либо иметь файл с сохраненными настройками.

Обновление версии php joomla

Что касается cms-joomla, то наверняка уже понятно, что процедура обновления версии php примерно выглядит одинаково. Вариантов достаточно много, но самое главное, что уже вся система работает на последней версии php после того, как вышла joomla 3.7.

При этом в панели администратора появится сообщение о несовместимости php не зависимо от того, на каком сервере работает система, локальном или удаленном.

Что касается установленных расширений, то зачастую в joomla не бывает больше 5-7 расширений которые необходимо обновить.

И информацию об обновлении всегда можно увидеть в админ-панели, но если некоторые расширения долго не обновляются, стоит на это обратить пристальное внимание.

 

Читайте также:

Оставить комментарий

avatar
  Хочу подписаться  
Уведомление на

Сообщить об опечатке

Текст, который будет отправлен нашим редакторам: